October 22, 2011

Authentication is required to mount

    Чтобы при обращении к внешним носителям не выскакивало сообщение "Authentication is required to mount ..." необходимо сделать следующее:

1. открыть с правами администратора файл:
/usr/share/polkit-1/actions/org.freedesktop.udisks.policy
2. в секциях action, имеющих следующие id:

a) org.freedesktop.udisks.filesystem-mount
b) org.freedesktop.udisks.filesystem-mount-system-internal
c) org.freedesktop.udisks.filesystem-umount-others (не всегда обязательно)

    значение элемента <allow_active> изменить с auth_admin на yes, например:
<action id="org.freedesktop.udisks.filesystem-mount">
  <description>Mount a device</description>
  <description xml:lang="da">Montér en enhed</description>
  <message>Authentication is required to mount the device</message>
  <message xml:lang="da">Autorisering er påkrævet for at montere et fil system</message>
  <defaults>
    <allow_any>no</allow_any>
    <allow_inactive>no</allow_inactive>
    <allow_active>yes</allow_active>
  </defaults>
</action>
   
    Следует отметить, что после обновления системы, возвожно, эту операцию придется выполнить вновь.

No comments:

Post a Comment